Morris Minor ShopMorris Down Under Forum Forum Index Classic Car Trader
Log in Register FAQ Memberlist Search Morris Down Under Forum Forum Index

problem

 
Post new topic   Reply to topic    Morris Down Under Forum Forum Index » Electrics, Instrumentation & Security
View previous topic :: View next topic  
Author Message
morris12
Got the hang of this ...


Joined: 21 Sep 2008
Posts: 232
Location: Wollongong, NSW

PostPosted: Sun Feb 03, 2013 5:48 pm    Post subject: problem Reply with quote

hi all,i got a problem ,starting my morry it starts evertime for about 3 days then then its flat i charge the battery for about half an hour then ok (battery near new) when i turn the ignition on the voltage drops from 13 volts to about 11 not enough to turn the motor over any suggestion would be appreciated. thankyou ps its datsun sunny motor.


Back to top
View user's profile Send private message Send e-mail
grant69
moderator


Joined: 27 Jan 2004
Posts: 2796
Location: Cairns Nth Qld

PostPosted: Sun Feb 03, 2013 9:29 pm    Post subject: Reply with quote

There are a few things that can cause your battery to go flat, do you have any accessories fitted, clock, radio, cb etc. 2nd could be a high resistance somewhere, this could be hard to find. Have you had your battery load checked bu a specialist. Most battery shops offer this as a free service, sometimes a battery can look ok but has a dud cell, each cell in a battery is 2v and your 12v battery will have 6 cells (numbers are rounded for simplicity) drop one under load and you lose 2vs. If you don't drive your morry often, you can fit a battery conditioner. Battery World do a maintenance charger which is a smart plug pack that trickle charges your battery and very low current and will turn itself on and off when your battery needs it. It comes with a special connector which stays on your battery and you unplug the power pack. I have one on my ute


Back to top
View user's profile Send private message Visit poster's website
zabond
Free Wheeling


Joined: 28 May 2012
Posts: 110
Location: Neerim East Victoria Australia

PostPosted: Mon Feb 04, 2013 7:40 am    Post subject: Reply with quote

If you mean the voltage drops 2v with just the ign on then you have a short or accesories are drawing to much current, but if you mean when you engage the startermotor then your starter could need looking at, also is your alternator charging?if you disconect the battery while the engine is running and it stops you have a alternator problem,to see if you have a short turn every thing off and disconect 1 battery lead then just touch it back on the terminal and see if there's a spark[easier at night in the dark]if theres a spark you have a short to earth some where
Russ


Back to top
View user's profile Send private message
morris12
Got the hang of this ...


Joined: 21 Sep 2008
Posts: 232
Location: Wollongong, NSW

PostPosted: Mon Feb 04, 2013 11:40 am    Post subject: Reply with quote

hi russ,charge the battery ,start the engine took the terminal off engine kept going and the starter motor already been done by auto elect i check for spark on battery none so i think it might be the battery as grant said so i check in my garage for a gadget i had years ago to suck out the water from the battery and the reading was recharge on 5 out 6 i dont khow how reliable it is. warren


Back to top
View user's profile Send private message Send e-mail
grant69
moderator


Joined: 27 Jan 2004
Posts: 2796
Location: Cairns Nth Qld

PostPosted: Mon Feb 04, 2013 11:55 am    Post subject: Reply with quote

Your suck the water out gauge is a hydrometer, they are very accurate and tell you the specific gravity of each cell, what this tells me is the acid levels are wrong in the battery, if its fairly new take it back under warranty and get them to sort it out


Back to top
View user's profile Send private message Visit poster's website
stracho
Full Licence


Joined: 25 Jun 2004
Posts: 592
Location: lake conjola

PostPosted: Mon Mar 04, 2013 12:25 pm    Post subject: battery Reply with quote

Hi warren one of the,common fault with a datsun conversion is that they forget to connect a earth strap from the motor or gearbox to the frame as the morris had this could be the problem



_________________
stracho
Back to top
View user's profile Send private message
morris12
Got the hang of this ...


Joined: 21 Sep 2008
Posts: 232
Location: Wollongong, NSW

PostPosted: Mon Mar 04, 2013 1:44 pm    Post subject: Reply with quote

hi john,i need a new battery which i got the car is going just fine i had the earth strap on thanks,i hope to see you before the rally regards warren


Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Morris Down Under Forum Forum Index » Electrics, Instrumentation & Security All times are GMT + 10 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001- 2004 phpBB Group
Theme created by phpBBStyles.com | Themes Database