Morris Minor ShopMorris Down Under Forum Forum Index Classic Car Trader
Log in Register FAQ Memberlist Search Morris Down Under Forum Forum Index

Horn not working.

 
Post new topic   Reply to topic    Morris Down Under Forum Forum Index » Electrics, Instrumentation & Security
View previous topic :: View next topic  
Author Message
brownstump47
Thanks ~ nice to be here


Joined: 06 Jun 2012
Posts: 12
Location: Hat Head NSW Australia

PostPosted: Sat Jul 23, 2016 1:01 pm    Post subject: Horn not working. Reply with quote

I hope this is where I should be. The horn on my Morris will not work. I had the indicator stalk fixed the other day & He bumped the horn & it worked but on my way home it would not blow.
How can I fix it please. I have pulled it out of the wheel & it looks OK.



_________________
Glen
Back to top
View user's profile Send private message
Boeing Bob
Got the hang of this ...


Joined: 08 Jul 2007
Posts: 278
Location: SYDNEY, AUSTRALIA

PostPosted: Sat Jul 23, 2016 8:34 pm    Post subject: Reply with quote

Have a good look at the bunch of connectors under the dash where the main loom connects to the column. If somebody has been tinkering with the column, there is a good chance that a wire has been pulled out.

Bob.



_________________
God bless Lord Nuffield and Sir Alec.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Morris Down Under Forum Forum Index » Electrics, Instrumentation & Security All times are GMT + 10 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001- 2004 phpBB Group
Theme created by phpBBStyles.com | Themes Database