Morris Minor ShopMorris Down Under Forum Forum Index Classic Car Trader
Log in Register FAQ Memberlist Search Morris Down Under Forum Forum Index

Ignition light

 
Post new topic   Reply to topic    Morris Down Under Forum Forum Index » Electrics, Instrumentation & Security
View previous topic :: View next topic  
Author Message
John Ballard
valued contributor


Joined: 11 Feb 2004
Posts: 2415
Location: Dubbo NSW

PostPosted: Thu Oct 01, 2020 7:27 pm    Post subject: Ignition light Reply with quote

I have a problem in my Ute with the red ignition light in the speedo. I have fitted a alternator from a Mini 45 amp/hr , I can accelerate from standing and the light just goes out as I change into 2nd gear and comes on again as I remove foot from accelerator to change gear again. I feel it is about 2500 revs.
Now my voltmeter is showing almost 14 volts constantly and I have not had flat battery yet.
One thought is the pilot light is L.E.D. so will remove glove box and change it.
Any thoughts.



_________________
" I still have all my marbles, they just roll slower "
Back to top
View user's profile Send private message Send e-mail
Scouse
moderator


Joined: 15 Sep 2003
Posts: 5199
Location: Wollondilly, NSW

PostPosted: Thu Oct 01, 2020 8:36 pm    Post subject: Reply with quote

The LED is only allowing current to go one way as it's a diode.
A normal globe will allow the current to go back to the alternator to get the exciter going. You're managing to get it going with revs but the old incandescent globe will make it work from idle.



_________________
Scott
Back to top
View user's profile Send private message
John Ballard
valued contributor


Joined: 11 Feb 2004
Posts: 2415
Location: Dubbo NSW

PostPosted: Thu Oct 01, 2020 9:44 pm    Post subject: Reply with quote

Try that tomorrow and let you know, however not keen on removing drivers glove box



_________________
" I still have all my marbles, they just roll slower "
Back to top
View user's profile Send private message Send e-mail
Scouse
moderator


Joined: 15 Sep 2003
Posts: 5199
Location: Wollondilly, NSW

PostPosted: Thu Oct 01, 2020 11:17 pm    Post subject: Reply with quote

Why remove the glovebox? Don't you have a screw access hole in the side of the liner?



_________________
Scott
Back to top
View user's profile Send private message
John Ballard
valued contributor


Joined: 11 Feb 2004
Posts: 2415
Location: Dubbo NSW

PostPosted: Sat Oct 03, 2020 1:28 pm    Post subject: Reply with quote

Yes but with the wiring and the heater hoses ,glove box is easier.
So done that fitted new incandescent globe no change. I will take it off tomorrow and get the auto elec. to check nit.



_________________
" I still have all my marbles, they just roll slower "
Back to top
View user's profile Send private message Send e-mail
John Ballard
valued contributor


Joined: 11 Feb 2004
Posts: 2415
Location: Dubbo NSW

PostPosted: Thu Oct 08, 2020 1:36 pm    Post subject: Reply with quote

Results from the Auto Elec was the slip rings were worn out. They could repair for $250 providing they could find parts a Lucas 17ACR. or new one for $300.
Managed to get a new one 45 amp rated from MG place for $190



_________________
" I still have all my marbles, they just roll slower "
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Morris Down Under Forum Forum Index » Electrics, Instrumentation & Security All times are GMT + 10 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001- 2004 phpBB Group
Theme created by phpBBStyles.com | Themes Database